DocsBot AI - Default OpenAI key 401 errors – Incident details

Default OpenAI key 401 errors

Resolved
Operational
Started 6 days agoLasted about 1 hour

Affected

Website

Partial outage from 4:00 PM to 4:27 PM, Operational from 4:27 PM to 4:49 PM

Chatbots

Partial outage from 4:00 PM to 4:27 PM, Operational from 4:27 PM to 4:49 PM

Updates
  • Resolved
    Resolved

    Our internal monitoring notified us immediately to the increased error rate and we began investigating.

    It appears that the internal OpenAI key we use by default for chatbots that have not added their own key was deleted from our OpenAI account. We have verified account security and that this deletion was inadvertent.

    After reissuing a new key and deploying all services should be back online. We apologize that this affected our customers, and will further restrict production key delete capabilities to make sure this won't happen again.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Bots using our default OpenAI credentials are returning an API key error message. We are investigating.